ロリポップサーバーで Composer を使う

ロリポップサーバーのコマンドラインでは curl が許可されていません。
Download Composer の2番目の方法を使ってダウンロードします。
注意しなければならないのはコマンドラインで php を使用する場合デフォルトは PHP 5.2 だということ。*1
パスを指定して実行します。

/usr/local/php5.4/bin/php -r "eval('?>'.file_get_contents('https://getcomposer.org/installer'));"

使用するときも

/usr/local/php5.4/bin/php composer.phar update

としてください。


【関連記事】
Windows PowerShell で Composer を使う

*1
パスを指定せず

php -r "eval('?>'.file_get_contents('https://getcomposer.org/installer'));"

を実行すると

Your PHP (5.2.17) is too old, you must upgrade to PHP 5.3.2 or higher.

と言われます。


カテゴリー: PHP タグ: , パーマリンク